Orders not coming through.
Resolved
May 1, 2026 at 3:57pm UTC
The issue with the billing panel has been resolved. Order processing is now functioning normally again.
All affected orders have been manually created, and compensation has been applied for the delay.
If you placed an order after 13:45 UTC on 30 April 2026 and have not received access or communication, please contact our support team.
Affected services
Created
Apr 30, 2026 at 5:27pm UTC
The billing panel issue resulting in failed order processing is currently being investigated. Orders placed after 13:45 UTC have not been successfully processed.
Once the underlying issue is resolved, each affected order will be manually created, and compensation will be provided for the delay. Further updates will be shared as they become available.
Affected services